$re = '/(.*-\d{8}$)/';
$str = 'www.example.com/anything-here/again-here/again-hello-12543598';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);