re = /(.*-\d{8}$)/
str = 'www.example.com/anything-here/again-here/again-hello-12543598'
# Print the match result
str.match(re) do |match|
puts match.to_s
end