import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "thumbnail_src\":(.*),\"is_video";
final String string = "\"thumbnail_src\":\"https:\\/\\/scontent-fra3-1.blablabla.com\\/t51.2885-15\\/s640x640\\/sh0.08\\/e35\\/1234567_984778981596410_1107218704_n.jpg\",\"is_video\":false";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}