// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"thumbnail_src":(.*),"is_video"#).unwrap();
let string = "\"thumbnail_src\":\"https:\\/\\/scontent-fra3-1.blablabla.com\\/t51.2885-15\\/s640x640\\/sh0.08\\/e35\\/1234567_984778981596410_1107218704_n.jpg\",\"is_video\":false";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}