import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9,.]+)(?:(?: [A-Za-z]+)? ([A-Z]{3}))?";
final String string = "$534\n"
+ "$22,136.20\n"
+ "3,200,000 Ft HUF\n"
+ "12,500 kr DKK\n"
+ "50,000 kr SEK\n"
+ "$3,800 AUD\n"
+ "$10,000 NZD\n"
+ "€4,500 EUR\n"
+ "¥100,000 CNY\n"
+ "₹7,000,000 INR\n"
+ "R$39,000 BRL";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}