import re
regex = re.compile(r"([0-9,.]+)(?:(?: [A-Za-z]+)? ([A-Z]{3}))?", flags=re.MULTILINE)
test_str = ("$534\n"
"$22,136.20\n"
"3,200,000 Ft HUF\n"
"12,500 kr DKK\n"
"50,000 kr SEK\n"
"$3,800 AUD\n"
"$10,000 NZD\n"
"€4,500 EUR\n"
"¥100,000 CNY\n"
"₹7,000,000 INR\n"
"R$39,000 BRL")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")