const regex = new RegExp('([0-9,.]+)(?:(?: [A-Za-z]+)? ([A-Z]{3}))?', 'gm')
const str = `\$534
\$22,136.20
3,200,000 Ft HUF
12,500 kr DKK
50,000 kr SEK
\$3,800 AUD
\$10,000 NZD
€4,500 EUR
¥100,000 CNY
₹7,000,000 INR
R\$39,000 BRL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}