using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^username\s+\d+\s+(?!.*grep).*some\/path\/somescript\.py$";
string input = @"username 842 93.0 0.1 180740 36016 ? Sl Jan21 747:36 /some/path/somescript.py
username 8227 0.0 0.0 14356 2496 pts/5 S+ 11:33 0:00 grep /some/path/somescript.py";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}