const regex = /^username\s+\d+\s+(?!.*grep).*some\/path\/somescript\.py$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^username\\s+\\d+\\s+(?!.*grep).*some\\\/path\\\/somescript\\.py$', 'gm')
const str = `username 842 93.0 0.1 180740 36016 ? Sl Jan21 747:36 /some/path/somescript.py
username 8227 0.0 0.0 14356 2496 pts/5 S+ 11:33 0:00 grep /some/path/somescript.py`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}