$re = '/^username\s+\d+\s+(?!.*grep).*some\/path\/somescript\.py$/m';
$str = 'username 842 93.0 0.1 180740 36016 ? Sl Jan21 747:36 /some/path/somescript.py
username 8227 0.0 0.0 14356 2496 pts/5 S+ 11:33 0:00 grep /some/path/somescript.py';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);