using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(19|20)(\d{2})-(\d{1,2})-(\d{1,2})";
string input = @"2012-03-04";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}