package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(19|20)(\d{2})-(\d{1,2})-(\d{1,2})`)
var str = `2012-03-04`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}