$re = '/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/';
$str = '2012-03-04';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);