const regex = /\[((?:(?!img).)*?)\](?:.*?)\[\/\1\]|\[img.*\](.*?)\[\/img\]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[((?:(?!img).)*?)\\](?:.*?)\\[\\\/\\1\\]|\\[img.*\\](.*?)\\[\\\/img\\]', 'gmi')
const str = `Hello, this is an example: [img]yyy[/img] - Yay!
[tt]this is a test [img]xxx[/img] [a]stuff [/a] yolo![/tt]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}