$re = '/\[((?:(?!img).)*?)\](?:.*?)\[\/\1\]|\[img.*\](.*?)\[\/img\]/mi';
$str = 'Hello, this is an example: [img]yyy[/img] - Yay!
[tt]this is a test [img]xxx[/img] [a]stuff [/a] yolo![/tt]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);