re = /\[((?:(?!img).)*?)\](?:.*?)\[\/\1\]|\[img.*\](.*?)\[\/img\]/mi
str = 'Hello, this is an example: [img]yyy[/img] - Yay!
[tt]this is a test [img]xxx[/img] [a]stuff [/a] yolo![/tt]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end