using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^A-Z\n]*[A-Z][^A-Z\n]*$|(?:[^A-Z\n]*[A-Z]){6,}).{8,}$";
string input = @"AAaaaaaa
Aaaaaaaa
AAAAAAaa ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}