re = /^(?=[^A-Z\n]*[A-Z][^A-Z\n]*$|(?:[^A-Z\n]*[A-Z]){6,}).{8,}$/m
str = 'AAaaaaaa
Aaaaaaaa
AAAAAAaa '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end