package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/\*(?:[\r\n]|[^\r\n])*\*/`)
var str = `/* first line.
the second line
The last line. */`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}