$re = '//\*(?:[\r\n]|[^\r\n])*\*//';
$str = '/* first line.
the second line
The last line. */';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);