re = /\/\*(?:[\r\n]|[^\r\n])*\*\//
str = '/* first line.
the second line
The last line. */'
# Print the match result
str.match(re) do |match|
puts match.to_s
end