using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(;[a-z][a-z](?=;))";
string input = @";af;aj;am;an;ao;ap12;aq123;ar;as;ad;af1223;";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}