const regex = /(;[a-z][a-z](?=;))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(;[a-z][a-z](?=;))', 'gs')
const str = `;af;aj;am;an;ao;ap12;aq123;ar;as;ad;af1223;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}