$re = '/(;[a-z][a-z](?=;))/s';
$str = ';af;aj;am;an;ao;ap12;aq123;ar;as;ad;af1223;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);