using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![ab]\/)(([^ \t\n\r\f\v:\""])+?\.(html|py|css|js|txt|xml|json|vue))(\"". line |:|\n| )(([0-9]+)*)";
string input = @"diff --git a/src/give/forms.py b/src/give/forms.py
M give/locale/fr/LC_MESSAGES/django.po
M agive/models/translation.py
M give/views.py
Some problem at give/widgets.py:103
Traceback (most recent call last):
File ""/usr/lib/python3.10/unittest/case.py"", line 59, in testPartExecutor
yield
File ""/usr/lib/python3.10/unittest/case.py"", line 587, in run
self._callSetUp()
File ""/usr/lib/python3.10/unittest/case.py"", line 546, in _callSetUp
self.setUp()
File ""/home/projects/src/give/tests/test_models.py"", line 14, in setUp
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}