const regex = /(?![ab]\/)(([^ \t\n\r\f\v:\"])+?\.(html|py|css|js|txt|xml|json|vue))(\". line |:|\n| )(([0-9]+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![ab]\\\/)(([^ \\t\\n\\r\\f\\v:\\"])+?\\.(html|py|css|js|txt|xml|json|vue))(\\". line |:|\\n| )(([0-9]+)*)', 'gm')
const str = `diff --git a/src/give/forms.py b/src/give/forms.py
M give/locale/fr/LC_MESSAGES/django.po
M agive/models/translation.py
M give/views.py
Some problem at give/widgets.py:103
Traceback (most recent call last):
File "/usr/lib/python3.10/unittest/case.py", line 59, in testPartExecutor
yield
File "/usr/lib/python3.10/unittest/case.py", line 587, in run
self._callSetUp()
File "/usr/lib/python3.10/unittest/case.py", line 546, in _callSetUp
self.setUp()
File "/home/projects/src/give/tests/test_models.py", line 14, in setUp
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}