$re = '/(?![ab]\/)(([^ \t\n\r\f\v:\"])+?\.(html|py|css|js|txt|xml|json|vue))(\". line |:|\n| )(([0-9]+)*)/m';
$str = 'diff --git a/src/give/forms.py b/src/give/forms.py
M give/locale/fr/LC_MESSAGES/django.po
M agive/models/translation.py
M give/views.py
Some problem at give/widgets.py:103
Traceback (most recent call last):
File "/usr/lib/python3.10/unittest/case.py", line 59, in testPartExecutor
yield
File "/usr/lib/python3.10/unittest/case.py", line 587, in run
self._callSetUp()
File "/usr/lib/python3.10/unittest/case.py", line 546, in _callSetUp
self.setUp()
File "/home/projects/src/give/tests/test_models.py", line 14, in setUp
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);