$re = '/(\.[^\<]+)<\/someTag>/';
$str = '<someTag>123.3</someTag>
<someTag>8623.34</someTag>
<anotherTag>12.3456</anotherTag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);