import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(\\/\\/ --- Literal)[\\r\\n]+|(\\/\\/ --- Edited)\\z|\\/\\/(.*[\\r\\n]*)";
final String string = "// --- Literal\n"
+ "//\n"
+ "//At the same time as that, joining in the music\n"
+ "//will be fun, I think.\n"
+ "// --- Edited";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}