$re = '/\A(\/\/ --- Literal)[\r\n]+|(\/\/ --- Edited)\z|\/\/(.*[\r\n]*)/i';
$str = '// --- Literal
//
//At the same time as that, joining in the music
//will be fun, I think.
// --- Edited';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);