const regex = /\A(\/\/ --- Literal)[\r\n]+|(\/\/ --- Edited)\z|\/\/(.*[\r\n]*)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(\\\/\\\/ --- Literal)[\\r\\n]+|(\\\/\\\/ --- Edited)\\z|\\\/\\\/(.*[\\r\\n]*)', 'gi')
const str = `// --- Literal
//
//At the same time as that, joining in the music
//will be fun, I think.
// --- Edited`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}