using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]+"")|^\S+|\W-\S+|(\S+)";
string input = @"test --par2 --par23=whatever 0 xd true hello ""string test""
or
test --par23=whatever 0 xd true hello --par2 ""string test""
or
test 0 xd ""string test"" true hello --par2 --par23=whatever";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}