package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("[^"]+")|^\S+|\W-\S+|(\S+)`)
var str = `test --par2 --par23=whatever 0 xd true hello "string test"
or
test --par23=whatever 0 xd true hello --par2 "string test"
or
test 0 xd "string test" true hello --par2 --par23=whatever`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}