$re = '/("[^"]+")|^\S+|\W-\S+|(\S+)/m';
$str = 'test --par2 --par23=whatever 0 xd true hello "string test"
or
test --par23=whatever 0 xd true hello --par2 "string test"
or
test 0 xd "string test" true hello --par2 --par23=whatever';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);