#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<=\G(\w+).+?)\n(?=\1)"
Local $sString = "Auth= bigben.com\\Dileja" & @CRLF & _
"Server = ringring.com" & @CRLF & _
"Config = teststringA" & @CRLF & _
"Auth= dingdong.com\\Debyyy" & @CRLF & _
"Server = testtest.com" & @CRLF & _
"Config = teststringB" & @CRLF & _
"Auth= dingdong.com\\Debyyy" & @CRLF & _
"Server = testtest.com" & @CRLF & _
"Config = teststringB" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")