const regex = new RegExp('(?<=\\G(\\w+).+?)\\n(?=\\1)', 'sg')
const str = `Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}