using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\G(\w+).+?)\n(?=\1)";
string input = @"Auth= bigben.com\\Dileja
Server = ringring.com
Config = teststringA
Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB
Auth= dingdong.com\\Debyyy
Server = testtest.com
Config = teststringB
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}