import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^https?:\\/\\/(?:w{3}\\.)?example\\.com\\/bar[12]\\/([^\\/]*)\\/?$";
final String string = "http://example.com/bar1/checkstatus\n"
+ "http://example.com/bar2/checkstatus\n"
+ "https://www.example.com/bar1/checkstatus\n"
+ "https://www.example.com/bar2/checkstatus\n"
+ "http://example.com/bar1/checkstatus/\n"
+ "http://example.com/bar2/checkstatus/\n"
+ "https://www.example.com/bar1/checkstatus/\n"
+ "https://www.example.com/bar2/checkstatus/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}