$re = '/(?i)^https?:\/\/(?:w{3}\.)?example\.com\/bar[12]\/([^\/]*)\/?$/m';
$str = 'http://example.com/bar1/checkstatus
http://example.com/bar2/checkstatus
https://www.example.com/bar1/checkstatus
https://www.example.com/bar2/checkstatus
http://example.com/bar1/checkstatus/
http://example.com/bar2/checkstatus/
https://www.example.com/bar1/checkstatus/
https://www.example.com/bar2/checkstatus/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);