// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^https?:\/\/(?:w{3}\.)?example\.com\/bar[12]\/([^\/]*)\/?$").unwrap();
let string = "http://example.com/bar1/checkstatus
http://example.com/bar2/checkstatus
https://www.example.com/bar1/checkstatus
https://www.example.com/bar2/checkstatus
http://example.com/bar1/checkstatus/
http://example.com/bar2/checkstatus/
https://www.example.com/bar1/checkstatus/
https://www.example.com/bar2/checkstatus/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}