#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Vue[\s]*\.[\s]*component\((["'`].*["'`]([\s]*|.*)),(([\s]*|.*)+?(\}\))[^\{])"
Local $sString = "import { ViewIndex } from "../../../../Utils.js";" & @CRLF & _
"" & @CRLF & _
"Vue.component('tab-control' , {" & @CRLF & _
" template: ViewIndex.getViewSync("tab-control")," & @CRLF & _
"" & @CRLF & _
" data() {" & @CRLF & _
"" & @CRLF & _
" return { tabs: this.$children ? this.$children : [] };" & @CRLF & _
" }," & @CRLF & _
" " & @CRLF & _
" created() {" & @CRLF & _
" " & @CRLF & _
" this.tabs = this.$children;" & @CRLF & _
" " & @CRLF & _
" }," & @CRLF & _
" methods: {" & @CRLF & _
" selectTab(selectedTab) {" & @CRLF & _
" this.tabs.forEach(tab => {" & @CRLF & _
" tab.isActive = (tab.name == selectedTab.name);" & @CRLF & _
" });" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
");" & @CRLF & _
"" & @CRLF & _
"Vue.component('tab-page', {" & @CRLF & _
"" & @CRLF & _
" template: `" & @CRLF & _
"" & @CRLF & _
" <div v-show="isActive">" & @CRLF & _
" <slot></slot>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
" `," & @CRLF & _
" " & @CRLF & _
" props: {" & @CRLF & _
" name: { required: true }," & @CRLF & _
" selected: { default: false }," & @CRLF & _
"" & @CRLF & _
" }," & @CRLF & _
" " & @CRLF & _
" data() {" & @CRLF & _
" " & @CRLF & _
" return {" & @CRLF & _
" isActive: false" & @CRLF & _
" };" & @CRLF & _
" " & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" mounted() {" & @CRLF & _
" " & @CRLF & _
" this.isActive = this.selected;" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
"})" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")