import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Vue[\\s]*\\.[\\s]*component\\(([\"'`].*[\"'`]([\\s]*|.*)),(([\\s]*|.*)+?(\\}\\))[^\\{])";
final String string = "import { ViewIndex } from \"../../../../Utils.js\";\n\n"
+ "Vue.component('tab-control' , {\n"
+ " template: ViewIndex.getViewSync(\"tab-control\"),\n\n"
+ " data() {\n\n"
+ " return { tabs: this.$children ? this.$children : [] };\n"
+ " },\n"
+ " \n"
+ " created() {\n"
+ " \n"
+ " this.tabs = this.$children;\n"
+ " \n"
+ " },\n"
+ " methods: {\n"
+ " selectTab(selectedTab) {\n"
+ " this.tabs.forEach(tab => {\n"
+ " tab.isActive = (tab.name == selectedTab.name);\n"
+ " });\n"
+ " }\n"
+ " \n"
+ " }\n"
+ "}\n\n"
+ ");\n\n"
+ "Vue.component('tab-page', {\n\n"
+ " template: `\n\n"
+ " <div v-show=\"isActive\">\n"
+ " <slot></slot>\n"
+ " </div>\n\n"
+ " `,\n"
+ " \n"
+ " props: {\n"
+ " name: { required: true },\n"
+ " selected: { default: false },\n\n"
+ " },\n"
+ " \n"
+ " data() {\n"
+ " \n"
+ " return {\n"
+ " isActive: false\n"
+ " };\n"
+ " \n"
+ " },\n\n"
+ " \n"
+ " mounted() {\n"
+ " \n"
+ " this.isActive = this.selected;\n"
+ " \n"
+ " }\n"
+ "})\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}