use strict;
my $str = 'import { ViewIndex } from "../../../../Utils.js";
Vue.component(\'tab-control\' , {
template: ViewIndex.getViewSync("tab-control"),
data() {
return { tabs: this.$children ? this.$children : [] };
},
created() {
this.tabs = this.$children;
},
methods: {
selectTab(selectedTab) {
this.tabs.forEach(tab => {
tab.isActive = (tab.name == selectedTab.name);
});
}
}
}
);
Vue.component(\'tab-page\', {
template: `
<div v-show="isActive">
<slot></slot>
</div>
`,
props: {
name: { required: true },
selected: { default: false },
},
data() {
return {
isActive: false
};
},
mounted() {
this.isActive = this.selected;
}
})
';
my $regex = qr/Vue[\s]*\.[\s]*component\((["'`].*["'`]([\s]*|.*)),(([\s]*|.*)+?(\}\))[^\{])/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}