package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[0-9]+.*$`)
var str = `/tracking_code/expire/2
/tracking_code/list
/tracking_code/expire/5/temp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}