$re = '/^.*[0-9]+.*$/m';
$str = '/tracking_code/expire/2
/tracking_code/list
/tracking_code/expire/5/temp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);