re = /^.*[0-9]+.*$/m
str = '/tracking_code/expire/2
/tracking_code/list
/tracking_code/expire/5/temp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end