package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[\da-z]+(?:-[\da-z]+)*$`)
var str = `sdh-sdj-dsjh-dh
fdgdfgdf
sjkk-sd-dd
-sdgdsj-djbjsd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}