re = /^[\da-z]+(?:-[\da-z]+)*$/mi
str = 'sdh-sdj-dsjh-dh
fdgdfgdf
sjkk-sd-dd
-sdgdsj-djbjsd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end