using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(file_exists|is_file)\(";
string input = @"if (is_file(str_replace(array('olddir'), array('newdir'), strtolower($file))){";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}