re = /(file_exists|is_file)\(/
str = 'if (is_file(str_replace(array(\'olddir\'), array(\'newdir\'), strtolower($file))){'
# Print the match result
str.match(re) do |match|
puts match.to_s
end